Canonical lançou uma atualização para corrigir uma vulnerabilidade

E novamente, a Canonical lançou uma atualização para corrigir uma vulnerabilidade. Confira os detalhes desse update e veja como instalar.

A Canonical é a empresa por trás do sistema operacional Ubuntu e está sempre atualizando o sistema para deixá-lo o mais seguro possível.

Agora, a Canonical lançou uma nova atualização de segurança do kernel do Ubuntu para resolver uma única vulnerabilidade que afeta todas as versões suportadas do Ubuntu.

Canonical lançou uma atualização para corrigir uma vulnerabilidade

Canonical lançou uma atualização para corrigir uma vulnerabilidade

Esta nova atualização de segurança do kernel do Linux chega apenas cinco dias depois que a Canonical lançou as principais atualizações do kernel para todas as versões com suporte do Ubuntu para corrigir um total de 17 vulnerabilidades e apenas aborda uma vulnerabilidade.

A vulnerabilidade de segurança é CVE-2020-14386, uma corrupção de memória AF_PACKET descoberta por Or Cohen.

Isso pode ser usado por um invasor local para travar o sistema vulnerável, causando uma negação de serviço ou possivelmente executar um código arbitrário.

Parece que o problema foi causado porque a implementação AF_PACKET falhou ao executar corretamente a verificação de limites em certas situações.

A falha também pode ser mitigada definindo o parâmetro sysctl kernel.unprivileged_userns_clone para 0 (por exemplo, $ sudo sysctl kernel.unprivileged_userns_clone = 0) se namespaces de usuário sem privilégios não forem necessários.

A Canonical marcou o problema com alta prioridade, portanto, você deve atualizar suas instalações para as novas versões do kernel o mais rápido possível.

Estes são linux-image-generic 5.4.0-47.51 para Ubuntu 20.04 LTS, linux-image-generic 4.15.0-117.118 para sistemas Ubuntu 18.04 LTS executando Linux 4.15 ou linux-image-generic 5.4.0-47.51 ~ 18.04.1 para sistemas Ubuntu 18.04.5 LTS executando o kernel Linux 5.4 HWE do Ubuntu 20.04 LTS.

Por outro lado, os usuários do Ubuntu 16.04.7 LTS usando o kernel Linux 4.15 HWE do Ubuntu 18.04 LTS devem atualizar suas instalações para linux-image-generic 4.15.0-117.118~16.04.1 e usuários do Ubuntu 18.04 LTS usando o kernel Linux 5.3. devem atualizar suas instalações para linux-image-generic 5.3.0-67.61.

Claro, novas versões do kernel também estão disponíveis para sistemas Raspberry Pi, processadores Qualcomm Snapdragon, sistemas OEM, ambientes em nuvem (KVM), sistemas Oracle Cloud, sistemas Google Container Engine (GKE) e Google Cloud Platform (GCP), bem como Amazon Sistemas Web Services (AWS) e Microsoft Azure Cloud.

Canonical lançou uma atualização para corrigir uma vulnerabilidade! É hora de atualizar

Para atualizar, simplesmente execute o comando sudo apt update && sudo apt full-upgrade em um emulador de terminal ou console virtual, ou use o utilitário Software Updater.

O que está sendo falado no blog

Categorias Linux, Notícias, Open Source, Software livre, Tecnologia, Ubuntu Tags atualização, Canonical, corrigir, lançou, Segurança, vulnerabilidade
Sair da versão mobile