Como corrigir o erro “google-chrome-stable depends on libxss1” na instalação do Chrome

Se você se deparou com o -chrome-stable libxss1” ao o Google Chrome a partir de um arquivo DEB, veja aqui como resolver esse problema.
Google_Chrome_22_on_Ubuntu_12.04
Esse erro acontece especialmente quando você acabou tenta instalar o Chrome em um novo sistema baseado no Debian, como o Ubuntu, Mint e outros. O erro ocorre mesmo quando você tenta fazer a instalação do pacote baixado a partir da Central de programas.

Por exemplo, ao executar o comando abaixo:


Veja também


sudo dpkg-i google-chrome-stable*.deb

O resultado são as mensagens de erro que podem ser conferidas abaixo:



Selecting previously unselected package google-chrome-stable.
(Reading database ... 162755 files and directories currently installed.)
Unpacking google-chrome-stable (from google-chrome-stable_current_amd64.deb) ... dpkg: dependency problems prevent configuration of google-chrome-stable:
google-chrome-stable depends on libxss1; however:
Package libxss1 is not installed.
dpkg: error processing google-chrome-stable (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support ...
Errors were encountered while processing: google-chrome-stable

Resolvendo o problema que causa o erro “google-chrome-stable depends on libxss1” na instalação do Chrome

Felizmente a solução do problema é simples e consiste em instalar manualmente as dependências que o Chrome precisa, para isso, faça o seguinte:
Passo 1. Abra um terminal (Usando o Dash ou pressionando as teclas CTRL+ALT+T);
Passo 2. Atualize o APT com o comando:

sudo apt-get update

Passo 3. Instale as dependências com o comando:

sudo apt-get install libgconf2-4 libnss3-1d libxss1

Passo 4. Agora instale o programa com o comando:

sudo dpkg -i google-chrome-stable*.deb 

Depois, basta ir no Dash e digitar: chrome


O que está sendo falado no blog hoje


Quer mais informações e dicas? Conheça também essas séries:

Edivaldo

Edivaldo Brito é analista de sistemas, gestor de TI, blogueiro e também um grande de fã de sistemas operacionais, banco de dados, software livre, redes, programação, dispositivos móveis e tudo mais que envolve tecnologia.

Website: http://www.edivaldobrito.com.br



blog comments powered by Disqus