Atualizando o kernel do Ubuntu para uma nova versão – 3.14.1

Saiu mais uma evolução do kernel Linux, a versão 3.14.1. Se você quiser experimentar, veja abaixo como atualizar o kernel do Ubuntu para essa versão de um jeito simples e rápido.
kernel-3.14
Como sempre, o kernel 3.14.1 traz várias melhorias importantes, como atualizações para algumas arquiteturas, novos recursos, bem como outras correções variadas e melhorias para alguns drivers.

Para ver as principais novidades desse kernel, acesse esse link.
Antes de iniciar começar a atualizar o kernel do Ubuntu, saiba que esta compilação é para o Ubuntu 14.04 e este é um procedimento que apesar de simples, exige conhecimentos avançados do sistema e deve ser feito por sua própria conta e risco.

Como atualizar o kernel do Ubuntu para a versão 3.14.1

Para atualizar seu kernel para a versão 3.14.1 do Ubuntu 14.04 e derivados, faça o seguinte
Passo 1. Abra um terminal (Usando o Dash ou pressionando as teclas CTRL+ALT+T);
Passo 2. Verifique qual a arquitetura de seu sistema acessando as Configurações do Sistema e a opção “Detalhes” ou usando o comando abaixo:

uname -m

Passo 3. Se estiver usando um sistema de 32 bits, baixe os arquivos DEB com os comandos:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/linux-headers-3.14.1-031401-generic_3.14.1-031401.201404141220_i386.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/linux-headers-3.14.1-031401_3.14.1-031401.201404141220_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/linux-image-3.14.1-031401-generic_3.14.1-031401.201404141220_i386.deb

Passo 4. Se estiver usando um sistema de 64 bits, baixe os arquivos DEB com os comandos:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/linux-headers-3.14.1-031401-generic_3.14.1-031401.201404141220_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/linux-headers-3.14.1-031401_3.14.1-031401.201404141220_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/linux-image-3.14.1-031401-generic_3.14.1-031401.201404141220_amd64.deb

Passo 5. Instale o kernel com o comando:

sudo dpkg -i linux-headers-3.14.1*.deb linux-image-3.14.1*.deb

Passo 6. Reinicie o sistema com o comando abaixo:

sudo reboot

Passo 7. Se você tiver algum problema e quiser desinstalar o atual kernel, reinicie o computador com um kernel anterior (usando Grub -> Advanced -> select previous kernel) e quando iniciar o sistema, faça login, abra um terminal e execute o comando abaixo para remover o Linux Kernel 3.14.1:

sudo apt-get remove linux-headers-3.14.1* linux-image-3.14.1*

Nota: Todos os drivers que não fazem parte da principal árvore do kernel (o que obviamente inclui drivers proprietários) devem ser recompilados para novas versões do kernel.

Via Kernel Ubuntu Team


Não está aparecendo algo?

Este post é melhor visualizado acessando direto da fonte. Para isso, clique nesse link.


O que está sendo falado no blog hoje


18 COMMENTS

  1. atualisando o kenel tambem da uma mensagem de erro com 4 linhas. isso acabou atrasando o reiniciar do sistema e deu erro para desinstalar . agora too tentando mudar o driver em driverss adicionais.

  2. Com a atualização do kernel para 3.14, não obtive sucesso com a instalação do nvidia-319-updates, que é o mais estável, ele dá um erro na instalação! Postando apenas para registro!
    Mensagem:

    Loading new nvidia-319-updates-319.60 DKMS files…

    Building only for 3.14.0-031400-generic

    Building for architecture x86_64

    Building initial module for 3.14.0-031400-generic

    ERROR (dkms apport): kernel package linux-headers-3.14.0-031400-generic is not supported

    Error! Bad return status for module build on kernel: 3.14.0-031400-generic (x86_64)

    Consult /var/lib/dkms/nvidia-319-updates/319.60/build/make.log for more information.

    Processando gatilhos para bamfdaemon …

    Rebuilding /usr/share/applications/bamf-2.index…

    Vou esperar a versão 14.04 para tentar novamente. Enquanto isso está perfeito o driver intel, porém há um certo aquecimento.

    • sudo apt-get install unity unity-common unity-services unity-lens-* unity-scope-* unity-webapps-* gnome-control-center-unity hud libunity-core-6* libunity-misc4 libunity-webapps* appmenu-gtk appmenu-gtk3 appmenu-qt* overlay-scrollbar* activity-log-manager-control-center firefox-globalmenu thunderbird-globalmenu libufe-xidgetter0 xul-ext-unity xul-ext-webaccounts webaccounts-extension-common xul-ext-websites-integration nautilus nautilus-sendto nautilus-sendto-empathy nautilus-share activity-log-manager-common python-zeitgeist rhythmbox-plugin-zeitgeist zeitgeist zeitgeist-core zeitgeist-datahub
      ou
      sudo apt-get install ubuntu-desktop

    • Amigo, isso é relativo ao Firmware que dá suporte ao UVD nas placas de vídeo ATI nos drivers open source. Se tu usa o catalisty, ignore o erro. Agora, se for usar o open source, use a PPA OIBAF, faça um apt upgrade e reinstale o kernel.

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.