Do not speak Portuguese? Translate this site with Google or Bing Translator

Canonical corrigiu regressão que causava falhas de inicialização em PC’s com AMD

Canonical corrigiu regressão que causava falhas de inicialização em PC’s com AMD. A empresa disponibilizou um patch para resolver o problema e pediu desculpas pelo incomodo. Confira os detalhes dessa atualização.


No mês passado, em 20 de junho de 2018, a Canonical lançou uma atualização de firmware de microcódigo da AMD para os sistemas Ubuntu 18.04 LTS (Bionic Beaver), Ubuntu 17.10 (Artful Aardvark), Ubuntu 16.04 LTS (Xenial Xerus) e Ubuntu 14.04 LTS (Trusty Tahr) para resolver a vulnerabilidade side-channel de microprocessador conhecida como Specter.

Canonical corrigiu regressão que causava falhas de inicialização em PC's com AMD
Canonical corrigiu regressão que causava falhas de inicialização em PC’s com AMD

Desenterrada por Jann Horn do Google Project Zero, a falha de segurança do Specter revelou o fato de que dispositivos alimentados por processadores modernos usando previsão de ramificação (branch prediction) e execução especulativa (speculative execution) podem permitir que invasores locais exponham informações sensíveis, incluindo memória do kernel, lendo a memória através do chamado ataques side-channel.

Infelizmente, o firmware do microcódigo do processador para processadores da AMD (amd64-microcode) lançado pela Canonical para sua versão Ubuntu Linux suportada causou falhas de inicialização em alguns PC’s.

Canonical corrigiu regressão que causava falhas de inicialização em PC’ s com AMD

No dia 5 de julho de 2018, a Canonical publicou um comunicado de segurança onde informava aos usuários da série do sistema operacional Ubuntu 14.04 LTS (Trusty Tahr) sobre uma regressão que causava falhas de inicialização em alguns PC’s com processadores AMD.

A Canonical pediu desculpas pelo problema e lançou um patch para consertar a infeliz regressão, e convidou todos os usuários a atualizarem seus PC’s imediatamente.

Sobre o assunto, a Canonical, disse o seguinte no alerta de segurança:

“O USN-3690-1 forneceu o microcódigo atualizado para os processadores da AMD para endereçar o CVE-2017-5715 (também conhecido como Specter). Infelizmente, a atualização causou falha em alguns sistemas. Essa atualização reverte a atualização para o Ubuntu 14.04 LTS. Pedimos desculpas pelo inconveniente.”

Neste momento, a Canonical corrigiu a referida regressão causada pela atualização do firmware do microcódigo da AMD apenas para usuários da série de sistemas operacionais Ubuntu 14.04 LTS (Trusty Tahr) e seus derivados oficiais, incluindo Kubuntu, Lubuntu, Xubuntu, etc.

A empresa afirma lançou a atualização no dia 5 de julho de 2018, para corrigir falhas de inicialização e reverter o update a partir de 20 de junho.

Portanto, para corrigir o problema, os usuários do Ubuntu 14.04 LTS devem atualizar a atualização do firmware do microcódigo da AMD para o pacote amd64-microcode-3.20180524.1~ubuntu0.14.04.2+really20130710.1 que agora está disponível nos repositórios oficiais de software.

Para atualizar seu sistema, siga as instruções em https://wiki.ubuntu.com/Security/Upgrades e lembre-se de reiniciar seus PCs após instalar a nova versão do microcódigo.

O que está sendo falado no blog

Compartilhe:
Sobre o Edivaldo Brito

Edivaldo Brito é analista de sistemas, gestor de TI, blogueiro e também um grande fã de sistemas operacionais, banco de dados, software livre, redes, programação, dispositivos móveis e tudo mais que envolve tecnologia.

Deixe um comentário

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.