Do not speak Portuguese? Translate this site with Google or Bing Translator
Publicidade

Canonical lançou importantes atualizações de segurança do kernel

Novamente, a Canonical lançou importantes atualizações de segurança do kernel para melhorar a segurança do Ubuntu. Confira os detalhes e atualize!

O Ubuntu é uma das distribuições Linux mais usadas atualmente, e por conta disso, também é um dos sistemas mais visados por ameaças. Para manter seu sistema o mais seguro possível, a Canonical trabalha duro sempre publicando atualizações que diminuem os riscos de falhas.

Agora, a Canonical publicou mais um conjunto de atualizações de segurança do kernel do Linux para todas as versões suportadas do Ubuntu para solucionar várias vulnerabilidades de segurança marcadas como importantes.

Canonical lançou importantes atualizações de segurança do kernel

Canonical lançou importantes atualizações de segurança do kernel
Canonical lançou importantes atualizações de segurança do kernel

Dentre os problemas de segurança cobertos por essa atualização, o mais importante corrigido foi descoberto na implementação de manipulação de etiquetas da rede SELinux por Matthew Sheets.

Enumerada como CVE-2020-10711, esta vulnerabilidade afeta o Ubuntu 20.04 LTS, 19.10, 18.04 LTS e 16.04 LTS e pode permitir que um invasor remoto cause uma negação de serviço (falha no sistema).

A nova atualização de segurança elimina outra vulnerabilidade importante, a CVE-2020-10751, que foi descoberta por Dmitry Vyukov no gancho de segurança SELinux netlink, que poderia permitir que um invasor privilegiado ignorasse Restrições do SELinux netlink, em sistemas Ubuntu 19.10 e Ubuntu 18.04 LTS usando kernels Linux 5.3 ou 5.0.

Um problema de segurança (CVE-2020-12770) descoberto no driver SCSI genérico (sg) do kernel do Linux, que tratava incorretamente certas condições de erro, também foi corrigido em todas as versões suportadas do Ubuntu. Isso pode permitir que um invasor privilegiado local cause uma negação de serviço (falha no sistema).

Afetando os sistemas Ubuntu 20.04 LTS executando o kernel Linux 5.4, bem como os sistemas Ubuntu 19.10 e 18.04 LTS executando o kernel 5.3, uma vulnerabilidade (CVE-2020-12768) descoberta na implementação do KVM, que pode permitir que um invasor local cause uma negação de serviço, foi corrigido também.

Também foi corrigido na nova atualização de segurança, uma vulnerabilidade (CVE-2020-13143) descoberta no driver de dispositivo USB Gadget, o que poderia permitir que um invasor local travasse o sistema ou expor informações confidenciais.

Essa falha estava afetando os sistemas Ubuntu 20.04 LTS executando o kernel Linux 5.4, bem como os sistemas Ubuntu 18.04 LTS e 16.04 LTS executando o kernel Linux 4.15.

Outros problemas corrigidos nesta importante atualização de segurança do kernel Linux incluem uma falha (CVE-2020-10732) no código de elf handling, permitindo que um invasor local exponha informações confidenciais (memória do kernel) nos sistemas LTS do Ubuntu 20.04, além de várias vulnerabilidades (CVE-2019-19039CVE-2019-19377CVE-2019-19036CVE-2019-19318CVE-2019-19813CVE-2019-19816) afetando a implementação do sistema de arquivos Btrfs nos sistemas Ubuntu 16.04 LTS executando o kernel Linux 4.15.

Também no sistema Ubuntu 16.04 LTS executando o kernel Linux 4.15, a nova atualização de segurança reduz uma falha (CVE-2019-16089) descoberta na implementação do dispositivo de bloco de rede (nbd), um problema (CVE-2019-19462) descoberto no kernel- > implementação de retransmissão no espaço do usuário e uma vulnerabilidade (CVE-2019-12380) descoberta no subsistema efi. Tudo isso pode permitir que um invasor local cause uma negação de serviço (falha no sistema).

Canonical lançou importantes atualizações de segurança do kernel – Bora Atualizar?

A Canonical recomenda que todos os usuários atualizem suas instalações o mais rápido possível para as novas versões do kernel Linux que estão disponíveis nos repositórios estáveis ​​do Ubuntu 20.04 LTS (linux-image 5.4.0-28.32), Ubuntu 19.10 e Ubuntu 18.04.4 LTS (linux-image 5.3.0-62.56), assim como o Ubuntu 18.04 LTS e 16.04.6 LTS (linux-image 4.15.0-109.110 e linux-image 4.15.0-107.108~16.04.1).

Para atualizar seus sistemas, execute o comando sudo apt-get update && sudo apt-get dist-upgrade no aplicativo Terminal. Após instalar com êxito as novas versões do kernel, reinicie os computadores.

O que está sendo falado no blog

Veja mais artigos publicados neste dia…

Pin It on Pinterest

Alterar definições de privacidade