DragonFlyBSD recebeu o código do driver AMD Radeon Graphics do Linux 4.9

Confira os detalhes do anuncio de que o DragonFlyBSD recebeu o código do driver AMD Radeon Graphics do Linux 4.9.!

O desenvolvedor François Tigeot informou que o DragonFlyBSD recebeu o código do driver AMD Radeon Graphics do Linux 4.9. Confira os detalhes desse port.

O DragonFly é um sistema operacional e ambiente projetado para ser a continuação lógica da série de sistemas operacionais FreeBSD-4.x. Esses sistemas operacionais pertencem à mesma classe do Linux, pois são baseados em ideais e APIs do UNIX.

DragonFlyBSD recebeu o código do driver AMD Radeon Graphics do Linux 4.9
DragonFlyBSD recebeu o código do driver AMD Radeon Graphics do Linux 4.9

Uma das maravilhas do mundo do software livre/código aberto é que códigos e ideias podem ser aproveitados ao máximo otimizando ainda mais o esforço de quem as criou. Um bom exemplo disso aconteceu recentemente

DragonFlyBSD recebeu o código do driver AMD Radeon Graphics do Linux 4.9

O desenvolvedor do DragonFlyBSD, François Tigeot, continuou fazendo um bom trabalho na atualização contínua do código do driver gráfico de seu kernel com um port do código-fonte gráfico AMD Radeon do kernel Linux, juntamente com componentes relacionados, como gerenciamento de memória TTM.

É um processo interminável para os BSDs inserirem novos códigos do Linux Direct Rendering Manager em seus kernels e abordarem vários ismos de Linux no processo.

Com o código divulgado durante a noite, o kernel do DragonFlyBSD agora está montando uma pilha de drivers Radeon da era Linux 4.9.

Esta atualização limpa o código, fornece melhor suporte ao DisplayPort, aprimoramentos para configuração do modo atômico, aprimoramentos de desempenho, melhor estabilidade e muito mais.

Esta foi apenas uma atualização do código Radeon com o código do driver gráfico da Intel não sendo tocado nesta rodada.

A atualização tocou mais de 180 arquivos.

Embora haja algumas consequências com as GPUs Southern Islands, agora desativando a aceleração de hardware.

Existem algumas falhas neste código de driver no Xfce 4.14 e, como tal, a aceleração OpenGL não está sendo exposta para GPUs S.I. por enquanto.

O que está sendo falado no blog

No Post found.

Veja mais artigos publicados neste dia…