Do not speak Portuguese? Translate this site with Google or Bing Translator

Lançada uma nova atualização de segurança do kernel 4.4 do Ubuntu 16.04 LTS

E foi lançada uma nova atualização de segurança do kernel 4.4 do Ubuntu 16.04 LTS. Confira os detalhes desse update e veja como atualizar seu sistema.

As versões LTS do Ubuntu são famosas por causa do seu suporte de longo prazo. Por conta disso, é comum haver mais de uma versão LTS sendo suportada ao mesmo tempo. por exemplo, nesse momento, temos o Ubuntu 16.04, 18.04 e 20.04 LTS.

Agora, a Canonical publicou hoje uma nova atualização de segurança do kernel Linux para sistemas Ubuntu 16.04 LTS executando os pacotes do kernel Linux 4.4 para abordar duas vulnerabilidades de segurança.

Lançada nova atualização de segurança do kernel 4.4 do Ubuntu 16.04 LTS

Lançada uma nova atualização de segurança do kernel 4.4 do Ubuntu 16.04 LTS
Lançada uma nova atualização de segurança do kernel 4.4 do Ubuntu 16.04 LTS

A nova atualização do kernel aborda dois problemas de segurança, nomeadamente CVE-2020-12771, uma falha descoberta no subsistema bcache do kernel do Linux que pode permitir que um atacante local cause uma negação de serviço, e CVE-2020-15393, uma vulnerabilidade descoberta por Kyungtae Kim no driver de teste USB, o que pode permitir que um invasor próximo fisicamente cause uma negação de serviço (exaustão de memória).

Todos os usuários do Ubuntu 16.04 LTS (Xenial Xerus) que executam o kernel Linux 4.4 padrão devem atualizar suas instalações para as novas versões do kernel, linux-image 4.4.0-187.217 para sistemas de 32 bits, 64 bits e PowerPC, linux-image-raspi2 4.4.0-1137.146 para sistemas Raspberry Pi (V7), linux-image-aws 4.4.0-1112.124 para sistemas Amazon Web Services (AWS), linux-image-snapdragon 4.4.0-1141.149 para processadores Qualcomm Snapdragon e linux-image-kvm 4.4.0-1078.85 para ambientes em nuvem.

Um novo kernel HWE (Hardware Enablement) do Ubuntu 16.04 LTS (Xenial Xerus) também foi lançado para usuários do Ubuntu 14.04 ESM (Trusty Tahr) executando o kernel Linux 4.4.

Além disso, o problema CVE-2020-12771 foi corrigido nos pacotes do kernel Linux 5.0 do Ubuntu 18.04 LTS (Bionic Beaver) para o Google Container Engine (GKE) e sistemas OEM. Os usuários devem atualizar para linux-image-gke 5.0.0-1046.47 e linux-image-oem-osp1 5.0.0-1067.72.

Como instalar a nova atualização de segurança do kernel 4.4 do Ubuntu 16.04 LTS

Atualizar seus sistemas para corrigir esses problemas de segurança envolve a execução dos comandos sudo apt-get update && sudo apt-get dist-upgrade em um emulador de terminal ou a execução do utilitário Software Updater.

Como de costume, após uma atualização do kernel, você terá que reiniciar o computador para fazer todas as alterações necessárias.

Além disso, tenha em mente que devido a uma mudança inevitável de ABI, você também terá que reconstruir e reinstalar quaisquer módulos de kernel de terceiros que possa ter instalado, que se você não desinstalou manualmente os metapacotes de kernel padrão como linux-generic, linux -powerpc, etc.

O que está sendo falado no blog

Veja mais artigos publicados neste dia…

Compartilhe:
Sobre o Edivaldo Brito

Edivaldo Brito é analista de sistemas, gestor de TI, blogueiro e também um grande fã de sistemas operacionais, banco de dados, software livre, redes, programação, dispositivos móveis e tudo mais que envolve tecnologia.