Canonical lançou um patch de segurança do Kernel para PowerPC

Confira o anúncio de que a Canonical lançou um patch de segurança do Kernel para PowerPC!

A Canonical lançou um patch de segurança do Kernel para para resolver um problema de segurança que afeta os sistemas de 64 bits.

O sistema da Canonical está sempre recebendo correções de segurança e melhorias. Mas isso não se restringe apenas as plataformas tradicionais, pois ele vai muito além do PC padrão que conhecemos.

Canonical lançou um patch de segurança do Kernel para PowerPC
Canonical lançou um patch de segurança do Kernel para PowerPC

Canonical lançou um patch de segurança do Kernel para PowerPC

A Canonical lançou uma nova de segurança do kernel Linux para várias de suas versões suportadas do Ubuntu Linux para resolver um problema de segurança que afeta os sistemas PowerPC de 64 bits.

Afetando os sistemas operacionais Ubuntu 19.04 (Disco Dingo), Ubuntu 18.10 (Cosmic Cuttlefish) e Ubuntu 18.04 LTS (Bionic Beaver), o novo patch de segurança do kernel Linux corrige uma vulnerabilidade (CVE-2019-12817) em PowerPC de 64 bits (ppc64el ) sistemas, que podem permitir que um atacante local acesse o conteúdo da memória ou corrompa a memória de outros processos.

De acordo com o aviso de segurança:

“Descobriu-se que o kernel do Linux não separava corretamente certos mapeamentos de memória ao criar novos processos de espaço do usuário em sistemas Power (ppc64el) de 64 bits. Um invasor local poderia usar isso para acessar o conteúdo da memória ou causar corrupção de memória de outros processos no sistema.”

Todos os usuários devem a atualizar seus sistemas imediatamente

Se você estiver usando os sistemas operacionais Ubuntu 19.04 (Disco Dingo), Ubuntu 18.10 (Cosmic Cuttlefish) ou Ubuntu 18.04 LTS (Bionic Beaver) em um sistema PowerPC (ppc64el) de 64 bits, é recomendado atualizar o kernel para a linux-image-5.0.0-19.20 no Ubuntu 19.04, linux-image-4.18.0-24.25 no Ubuntu 18.10 e linux-image-4.18.0-24.25~18.04.1 no Ubuntu 18.04.1 LTS ou posterior.

Para atualizar seu sistema, siga as instruções fornecidas pela Canonical em https://wiki.ubuntu.com/Security/Upgrades.

E claro, lembre-se de reiniciar seu sistema após aplicar a nova versão do kernel para que o problema de segurança seja corrigido corretamente.

Além disso, você pode precisar recompilar e reinstalar quaisquer módulos de kernel de terceiros que você possa ter instalado.

Se você não desinstalou manualmente os meta-pacotes de kernel padrão linux-generic, linux-generic-lts-RELEASE, linux-virtual e linux-powerpc, o mecanismo de atualização do sistema cuidará automaticamente dos seus módulos de kernel de terceiros.

Para continuar mantendo seu sistema seguro, lembre-se de sempre manter seu sistema operacional e instalar os aplicativos atualizados em todos os momentos.

O que está sendo falado no blog

Veja mais artigos publicados neste dia…

Ajude a manter o Blog do Edivaldo - Faça uma doação

Se você gosta do conteúdo do Blog, você pode ajudar a manter o site simplesmente fazendo uma doação única, esporádica ou mensal, usando uma das opções abaixo:

Doação usando Paypal

Doação usando PagSeguro
Outras formas de ajudar a manter o Blog do Edivaldo