Como instalar codecs, Java e suporte a reprodução de DVD encriptado

Descubra como instalar codecs, Java e suporte a reprodução de DVD encriptado no Ubuntu!

Depois de instalar o Ubuntu, sempre fica faltando aqueles “pequenos” ajustes no sistema, e para ajudar nisso, veja como instalar codecs, Java e suporte a reprodução de DVD encriptado.

Nessa dica, será mostrado como instalar codecs, Java e o suporte a reprodução de DVD encriptado. São três coisas bem básicas, mas que por questões legais, não veem prontas no Ubuntu.

Como instalar codecs, Java e suporte a reprodução de DVD encriptado
Como instalar codecs, Java e suporte a reprodução de DVD encriptado

Como instalar codecs, Java e suporte a reprodução de DVD encriptado

A seguir, você verá como instalar codecs, Java e suporte a reprodução de DVD encriptado, para deixar seu sistema pronto para usar essas tecnologia. Confira!

Instalando codecs no Ubuntu

Para ser capaz de reproduzir a maioria dos formatos de áudio e vídeo, instale o pacote Ubuntu Restricted Extras, Para isso, faça o seguinte:

Passo 1. Abra um terminal (Usando o Dash ou pressionando as teclas CTRL+ALT+T);
Passo 2. Instale o suporte a codecs usando o seguinte comando:

sudo apt-get install ubuntu-restricted-extras -y

Sugiro instalar também as versões irrestritas de libavformat e libavcodec, assim você não encontrará problemas com codecs em falta ao tentar usar alguns editores de vídeo ou transcodificadores (transcoders).

Você pode instalá-los, abrindo um terminal e usando o seguinte comando:

sudo apt-get install libavcodec-extra libav-tools -y

Instalando Java no Ubuntu

Você também pode precisar de Java, mas antes, tem que descobrir o que você precisa.

A maioria dos usuários só precisam do OpenJRE e o plugin Java para o navegador que você pode instalar abrindo um terminal e usando o seguinte comando:

sudo apt-get install icedtea-8-plugin openjdk-8-jre

Para o desenvolvimento, você também vai querer instalar o OpenJDK que você pode instalar abrindo um terminal e usando o seguinte comando:

sudo apt-get install openjdk-8-jdk

Se, por várias razões, for necessário o Java da Oracle (o pacote inclui JDK, JRE e o plugin para o navegador), você pode instalar o Oracle Java 8, fazendo o seguinte:

Passo 1. Abra um terminal;
Passo 2. Se você já tiver instalado o OpenJDK, remova ele executando o seguinte comando:

sudo apt-get purge openjdk*

Passo 3. Se ainda não tiver, adicione esse repositório com o seguinte comando:

sudo add-apt-repository ppa:webupd8team/java

Passo 4. Atualize o APT com o comando:

sudo apt-get update

Passo 5. Instale o programa com o comando:

sudo apt-get install oracle-java8-installer

Passo 6. Depois de executar o instalador, concordar com os termos de uso e finalmente baixar e instalar o Java, se for necessário configurar automaticamente as variáveis ​​de ambiente Java, você pode instalar o seguinte pacote:

sudo apt-get install oracle-java8-set-default

E se você usa o Ubuntu 18.04 ou superior, use esse tutorial:

Como instalar o Oracle Java no Ubuntu 18.04 LTS

Instalando o suporte a reprodução de DVD encriptado

Para ativar o suporte a reprodução de DVD encriptado é necessário instalar a biblioteca livdvdcss, para isso, abra um terminal e faça o seguinte:

Passo 1. Instale a biblioteca libdvdread com o seguinte comando:

sudo apt-get install libdvdread4 -y

Passo 2. Execute o script de instalaçao da livdvdcss com o seguinte comando:

sudo apt-get install libdvdcss2 -y

O que está sendo falado no blog

Veja mais artigos publicados neste dia…

97 COMMENTS

  1. Olá Edivaldo, estou instalando o Java, tudo roda legal na instalação até aparecer no Terminal uma mensagem de ‘configurando pacotes’.

    Mas eu não consigo avançar, como dou o OK pra isso?

    Já agora, obrigado por tantas informações, um novato como eu não pode prescindir de um blog assim.

      • Ele não habilita nenhum OK ou SIM…

        Aparece no Teminal:

        ─────┤ Configurando ttf-mscorefonts-installer ├─────────────────┐

        …………..
        │ contact Microsoft for any reason, please contact the Microsoft

        │ subsidiary serving your country, or write: Microsoft Sales Information

        │ Center/One Microsoft Way/Redmond, WA 98052-6399.
        │ Reference: http://www.microsoft.com/typography/fontpack/eula.htm

        Mas veja, esse OK que aparecena mensagem não é um comando habilitado ou algum botão.

      • Bom, consegui confirmar a instalação clicando num espaçao da janela do terminal fora do balão de configurando pacotes.

        Mas o tal do Java não funciona no Chromium, não consigo ativar ele no browser. Infelizmente no Firefox não aceita o acesso a Caixa, diz que o ‘ambiente’ não aceita… Essas coisa que desanimam a gente par ao Linux quanto migramos do Windows.

        Nem a impressora tá funcionando, e olha que instalei e ela aparece no Ubuntu.

        Amanhã quem sabe funciona. Valeu pelas dicas.

  2. Edivaldo… me socorre… eu tava usando o DeVeDe normalmente no 13.10 64bits q de inicio deu erro de bug do Mencoder mas resolvi facil… agora fui pro 14.04 LTS 64bits e o programa DeVeDe ta dando o msm erro, e do jeito antigo de ir em “EDIT, PREFERENCES, ENCODER FOR VIDEOS: mencoder. Nao ta funcionando… e faço dvds sem menu,nao faço questao de menus. Ai eu mexi tanto nele q ele começou a falar q eu nao tinha espaço suficiente… tenho um HD interno de 2TB e um USB de 1TB… espaço não é msm… certeza… Mexi mais um pouco e msm msg de erro do mencoder… nao to conseguindo nem no ConvertXtoDVD via wine… da um erro na codificação do audio…
    Se vc souber de alguma solução ou de outro programa q faça o msm (sem menu). Desde ja… obrigado!

      • Fiz o q vc falou e agora assim q mando avançar pra começar a conversão aparece a seguinte msg: Falha ao gravar no diretorio de destino. Verifique se há permissões e espaço livre suficiente”.
        Troquei a pasta “tmp” de novo tanto pro HD interno quanto pro usb e a msm mensagem de erro: Conversão falhou. Parece ser um bug do Mencoder. :'(

          • Amigo… sou leigo no Linux… as coisas q sei fazer é tudo q pesquiso na net e nunca tive problema… esse negocio de permissões não sei do q se trata, mexi aqui e nd… pesquisei pra caramba e não achei resposta pro meu problema… eu tenho o windows em dual boot com o ubuntu, mas só pq preciso do Sony Vegas… ai tive q usar o ConvertXtoDVD no windows, pois tava meio apressado… vc nao conhece algum outro programa q faça o msm do DeVeDe?

          • vc ja usou ele? gostou do resultado?
            Pq eu fiz um dvd com ele, porem no windows… e a imagem ficou sem qualidade… com uns pixels meio verdes… e eu uso o DeVeDe pq ele aceita arquivos mkv… eu fiz um teste aki… e ele converteu e finalizou todo filme em avi… mas em mp4 ou mkv ele dá aquela msg de erro de bug…
            Vc poderia fazer msm esse post e de quebra ensinar fazer um DVD com ele, pode ser bem simples sem menu…
            Mas vou instalar esse e tentar aqui e posto se obtive sucesso ou pelo menos algo satisfatorio…
            Obrigado pela ajuda amigo!

          • Tentei novamente com o DeVeDe depois de remover e de utilizar o Ubuntu Tweak e limpar o “Cache Apt” e depois apt-get update… reinstalei… e funcionou em partes… só ta funcionando com arquivos .avi… ja com mp4 ou mkv ele parou com a msg de bug, porem finaliza a iso do DVD com 33min. ai quando vou ver a pasta so tem 350mb e nao consigo rodar ele nem no VLC…
            Ja esse DVDStyler… ja tinha usado em uma ocasião… mas o DeVeDe é bem simples e direto… pois bem… resolvi testar o Styler e quando tudo parecia bem… hou o seguinte erro:

            “Multiplexação de legendas

            Multiplexação legendas 1 de 1

            Executar o comando:spumux -P -s 0 “/media/dannyell/CE2867CE2867B3DD/ZTEMP//dvd-cache/entry001.vob_spumux.xml”

            DVDAuthor::spumux, version 0.7.0.

            Build options: gnugetopt imagemagick iconv freetype fribidi fontconfig

            Send bug reports to

            INFO: no default video format, must explicitly specify NTSC or PAL

            INFO: Opened iconv descriptor. *UTF-8* <= *UTF-8*

            ERR: Error 84 — Invalid or incomplete multibyte or wide character — decoding subtitle file at approx line pos 1 + char pos 47

            Falha"

            Alguma dica?
            PS.: Só Uso arquivos .mp4 ou .mkv dual audio e com legenda.

          • Edivaldo… Por sua causa, eu virei o DVDStyler ao averso, kkkkkk… eu me toquei que todos os programas usam legendas com configuração ISO 8859-16… e o programa tava com UTF-8. Não sei o q significa, mais foi so editar isso e resolveu… fiz todas as minhas configurações e to achando ele melhor q o DeVeDe… Ta tudo 100%.. audio e video.
            Muito obrigado pela ajuda!!! Sempre q preciso de algo seu site ta no meus favoritos pq sempre resolve meu problema.
            Parabéns pelo trabalho… Sucesso… Obrigado!!!

          • Valeu, Dannyel. O que você mexeu foi na codificação, o que realmente é um problema comum atualmente, isso acontece com legenda, com página de Internet e até nomes de arquivos (é um troço chato mesmo, mas é necessário).

  3. Olá Edivaldo , apareceu a seguinte mensagem.

    E: Impossível encontrar o pacote flashplugin-installer.
    E: Não foi possível encontrar o pacote através da expressão regular ‘flashplugin-installer.’

    Gostaria de saber como proceder?

  4. Bom dia!

    Atualizei o Ubuntu de 13.10 para 14.04 através do Manager Update do próprio sistema, e após dois dias, ele não reconhece mais as portas USB.

    Gostaria de pedir uma ajuda por favor?

    Saída do comando lsusb:

    Bus 002 Device 004: ID 0cf3:e004 Atheros Communications, Inc.
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 005: ID 0c45:648b Microdia Integrated Webcam
    Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
    Bus 001 Device 003: ID 138a:0011 Validity Sensors, Inc. VFS5011 Fingerprint Reader
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    Eu sinceramente não consigo entender porque não funciona.

  5. Engraçado, estou com o Lubuntu desde o alfa, no alfa me surpreendi pois não houve nenhum erro bizarro, justamente quando chega na versão final o responsável ou responsáveis pelo desenvolvimento do Lubuntu nos “presenteia” com o desaparecimento do Network Manager, corrigi aqui com a sua dica Edivaldo, muito obrigado! não creio que eles corrijam tal bug pois é um bug que está explícito, só quem não usa internet não perceberia, mesmo assim até hoje nada de correção oficial.

  6. Olá Edivaldo. Gostei bastante do Ubuntu, só que tenho tido um problema com relação a internet wifi e fazendo algumas pesquisas vi que muita gente também tem.

    O problema é com a placa wireless Atheros AR9485, que no meu caso não está funcionando 100%. A conexão fica uns 40% mais lenta no Ubuntu comparado ao Windows 8.

    Por acaso você tem conhecimento sobre esses casos e saberia dizer o que dá pra fazer?

    Obrigado.

  7. Fala Edivaldo estou com o LUBUNTU 14.04 LTS numnetbook ASUS EeeP7 como faco para insalar o restricted-extra pelo terminal. E para fazer funcionar a webcam no facebook.
    Valleu fico no aguardo…AntonioCarlos

  8. Edivaldo, o libav-tools já estava instalado e mesmo assim o WinFF e o
    Selene não funcionam. No WinFF o erro é: incapaz de encontrar o ffmpeg
    nem o avconv

    Claro que não deixo de visitar. Na verdade é o blog sobre ubuntu que mais visito.

  9. Bom Dia Edivaldo,

    Instalei o Ubuntu 14.04 e percebi que o LibreOffice Writer está com sua janela bugada… Ao menos no meu Note. Interessante que o Calc, o Base, o Impress funcionam perfeitamente… É só o Writer e a janela principal do programa.
    Não aparece as opções expandir, minimizar e fechar na janela… e o programa só ocupa parte da tela.
    Você observou isto? Teria alguma sugestão de como resolver?
    Obrigado e parabéns pelo Site.

    Marcelo David

  10. Olá tudo bom? Instalei o Ubuntu 14.04 junto com o windows 8, mais estou sentindo as páginas pesadas pra abrir, está demorando muito pra carregar, o que pode ser? Abraço.

  11. Bom dia Edivaldo, gostaria de saber duas coisas:
    1 – Tentei fazer o WinFF funcionar para converter arquivos multimídia, porém o Ubuntu não traz mais o ffmpeg e o substituiu pelo avconv. Como faço pra instalar o avconv?
    OBS: já tentei instalar o ffmpeg pelo ppa mas não funciona tb.

    2 – Eu ADOREI a ideia das páginas com os resumos de 2013 e 2014 (me guio por ela qdo preciso de ajuda), Tem algum comando do wget para eu poder baixar os conteúdos dessas páginas e guardá-los?

    Agradecido,

  12. Bom dia, Edivaldo!

    Encontro o seguinte erro:

    sudo apt-get install libavformat-extra-53 libavcodec-extra-53

    Reading package lists… Done

    Building dependency tree

    Reading state information… Done

    Package libavcodec-extra-53 is not available, but is referred to by another package.

    This may mean that the package is missing, has been obsoleted, or

    is only available from another source

    However the following packages replace it:

    libav-tools:i386 libav-tools

    Package libavformat-extra-53 is not available, but is referred to by another package.

    This may mean that the package is missing, has been obsoleted, or

    is only available from another source

    E: Package ‘libavformat-extra-53’ has no installation candidate

    E: Package ‘libavcodec-extra-53’ has no installation candidate

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.