Patch do Debian Está Causando Falhas de Inicialização em Sistemas ARM

Confira os detalhes do alerta de que a recente atualização do Debian está causando falhas de inicialização em sistemas ARM!

O projeto Debian alertou que o a recente atualização do Debian está causando falhas de inicialização em ARM. Confira os detalhes do problema e veja como resolver.


Também conhecida como Foreshadow, (L1 Terminal Fault) é uma vulnerabilidades de segurança semelhante às falhas e permitem que um invasor com acesso a um processo sem privilégios leia a memória de endereços arbitrários que não são controlados pelos usuários, inclusive do kernel.
Patch do Debian Está Causando Falhas de Inicialização em Sistemas ARM
Patch do Debian Está Causando Falhas de Inicialização em Sistemas ARM

Para corrigir as duas vulnerabilidades de segurança L1TF (CVE-2018-3620 e CVE-2018-3646), os usuários do Debian tiveram que atualizar seus kernels para a versão 4.9.110-3+deb9u4 e também instalar a última atualização de firmware de microcódigo de processadores do Debian através dos repositórios non-free.

Patch do Debian Está Causando Falhas de Inicialização em Sistemas ARM

Agora, Salvatore Bonaccorso, do Projeto Debian, informou aos usuários do sistema operacional Debian 9 Stretch sobre uma correção para uma regressão que causa falhas de inicialização em arquiteturas ARM.

Em um comunicado de segurança recente, Salvatore Bonaccorso escreve que a última atualização do kernel Linux lançada para o Debian 9 Stretch para corrigir as vulnerabilidades de segurança L1TF (L1 Terminal Fault/Foreshadow) está causando falhas de inicialização para usuários na arquitetura ARM.

Então, se você está usando o Debian 9 Stretch em uma máquina ARM, e você atualizou o pacote do kernel para a versão mencionada acima, você pode ter experimentado falhas na inicialização.

Portanto, um patch está disponível para corrigir essa regressão por meio de uma nova atualização do kernel do Linux.

Segundo o alerta de segurança:

“A atualização de segurança anunciada como DSA 4279-1 causou regressões nas arquiteturas ARM (falhas de inicialização em alguns sistemas). Pacotes atualizados estão disponíveis para corrigir este problema. Nós recomendamos que você atualize seus pacotes linux.”

Para consertar a regressão em seus sistemas ARM rodando o Debian 9 Stretch, você deve atualizar o kernel do seu sistema Debian para a versão 4.9.110-3+deb9u4, usando as atualizações de sistema.

E claro, lembre-se de reiniciar sua máquina depois de instalar a nova versão do kernel do Linux em seu sistema.

O que está sendo falado no blog



blog comments powered by Disqus