Kernel 4.18 parece estar causando problemas em CPUs mais antigas

Confira os detalhes dos relatos de que o Kernel 4.18 parece estar causando problemas em CPUs mais antigas e veja como resolver!

Alguns usuários estão relatando que o Kernel problemas em CPUs mais antigas. Confira os detalhes desse problema e veja como resolver.


Como em qualquer outro software, o desenvolvimento do kernel não é isento de problemas. Por conta da grande variedade de hardware e software que o kernel precisa cobrir isso sempre pode acontecer.
Kernel 4.18 parece estar causando problemas em CPUs mais antigas
Kernel 4.18 parece estar causando problemas em CPUs mais antigas

Felizmente, a velocidade com que as pessoas relatam os problemas e os desenvolvedores o resolvem, torna tudo muito rápido e ajuda a ter um kernel sempre funcional.

Kernel 4.18 parece estar causando problemas em CPUs mais antigas

Usuários que gostam de atualizar rapidamente para novos lançamentos principais do kernel, mas estão fazendo isso em hardware mais antigo, fiquem alertas: Parece que existe um bug que paralisa a inicialização no kernel 4.18.

Um leitor do site Phoronix divulgou as descobertas que ele e vários outros usuários do Arch Linux descobriram sobre um problema na execução do kernel 4.18, que parece estar isolado aos processadores Intel Core 2 Duo.

Ao inicializar usando o kernel 4.18 (pelo menos até o 4.18.5), haverá uma parada na inicialização do sistema seguido por um travamento total.

Os usuários do Arch Linux trocaram mensagens sobre este problema através deste tópico do fórum. Há pelo menos dois relatórios de bugs upstream (um e dois), sobre esse problema.

Aqueles que encontraram este problema já o cadastraram como um commit problemático, para que seja resolvido.

Se a compilação do kernel do Linux 4.18 com o commit for revertida, as CPUs antigas voltarão a funcionar normalmente nesta última versão estável do kernel.

Outra alternativa para solucionar esse problema é inicializar o PC com o seguinte parâmetro de kernel:

clocksource=hpet

Claro que, se você estiver executando em um sistema tão antigo quanto o Core 2 Duo (2006 ~ 2010), você pode escolher qualquer uma das versões mais antigas do kernel LTS para inicializar seu sistema, até que esta situação seja resolvida no upstream do kernel e criado um backport para a série 4.18.

Veja também

Linux para computadores antigos – conheça algumas distribuições

O que está sendo falado no blog



blog comments powered by Disqus